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1.  Introduction 

In order to satisfy the specific needs for improving the real time forecasting and 

warning system capabilities in Prut and Siret transboundary River Basins, the following 

hydrological and meteorological forecasting components have been implemented by 

the project partners: 

• A detailed spatial and temporal scale hydrological model for the upper part of 

the Siret and Prut River basins, in Ukraine, in order to provide short term 

detailed rainfall-runoff, and flood routing capabilities. 

• A high resolution local numerical weather prediction model is used to provide 

adequate, improved quantitative precipitation forecasts. 

• For the same area, for the routing and the flood inundation mapping needs, a 

hydraulic model was implemented. 

• A second type of model, a conceptual hydrological rainfall-runoff model was 

implemented, in order to satisfy the needs of medium term forecasts and 

scenarios analysis for the Siret and Prut river basins at the entrance in Romania. 

• These forecasts will be used both by the partners from Romania and Moldova, 

in order to optimize the operation of Stânca-Costeşti reservoir for flood defense 

in Prut river basin, and by Romanian partners for optimize the operation of 

reservoirs on Siret river. 

• For the Prut River, downstream the entrance in Romania, a hydraulic model 

was implemented by the Romanian and Moldavian partners, based on HEC-RAS 

hydraulic model, including the Stânca Costeşti reservoir. This hydraulic model 

was used for the flood hazard maps generation on Prut River, and will also be 

used for more accurate real-time forecasts during extreme flood events. 

 

2. Meteorological Forecasting System based on the Numerical Weather Prediction 
Model WRF  

Weather Research and Forecasting (WRF) Model is a contemporary mesoscale 

numerical weather prediction system designed for both atmospheric research and 

operational forecasting needs by several USA agencies and universities. The input data 

for the regional implementation of WRF can be download from the servers NOMADS 

of the USA agency http://nomads.ncep.noaa.gov/ 

Within the EAST AVERT  the software system was developed and installed in the 

server on Chernovtsy ( in DPDWM ) for  the four times per 24 hours automatic 

computing of the detailed weather forecast in the areas of the Prut and Siret basin in 

http://nomads.ncep.noaa.gov/
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Ukraine up to 7 days on the basis of the automatic retrievals of the global model 

results from the  NOMADS servers/ 

The simulations are performed on a sequence of 3 nested domains (Fig. 1) with 

the outer (first) domain having resolution of 27 km, second domain having resolution 

of 9 km and the inner (third domain) having resolution 3 km (Fig. 1, 2).  

The model parameters were calibrated on the weather obseravtuon data to 

increase the predictive power of WRF for this specific mountain region (Fig. 3)  

The results of WRF simulation are transferring from DPDWM to ChHMC for the 

further use as the input information for the operational Rainfall- Runoff model.  

 

Fig. 1 Three nested domains of the WRF model customized for the basins of the Prut and Siter 

rivers in Ukraine 
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Fig. 2 Internal domain of WRF- PRUT - UA model, with the grid 3*3 km 

 
Fig. 3 The distribution of the day sum of the precipitation simulated by WRF in the period of 

the extrem flood 25.07.2008  and observed precipitation at several monitoring stations 
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3.  Hydrological Rainfall-Runoff Model TOPKAPI-UKRAINE 

TOPKAPI model is fully distributed rainfall-runoff model based on combining GIS 

data and kinematic wave approach. Due to its distributed nature model in easy way 

can assimilate the results of numerical weather prediction systems (in our case 

regional WRF model).  

Original TOPKAPI model was developed at the University of Bologna. Many 

research groups around the world have been developed own implementations of 

TOPKAPI models that were used for hydrological studies and flood forecasting 

systems. Ukrainian Center of Environmental and Water Projects (UCEWP) developed 

own code of TOPKAPI model (TOPKAPI-U) and successfully used it before for 

hydrological studies of Ukrainian rivers of Transcarpathian region. TOPKAPI-U 

comprises modules that describe interception, evapotranspiration, snow accumulation 

and snow melting, subsurface flow, overland flow, channel flow processes.  

Model is used for flow calculation from  upper subwatersheds of Prut and Siret 

basins and for lateral inflow calculation to river networks for further routing. 

 

Collected historical hydrometeorological data models setup 

There are 16 manual hydrological gauging stations and 5 meteostations within 

Ukrainian part of Prut and Siret river basins. Hydrological stations carry out twice 

observations per day during normal situations (at 8:00 and 20:00 local time) and every 

4 hour during floods. Meteostations perform observations in terms established by 

World Meteorological Organization: precipitation is measured every 6 hours and air 

temperature every 3 hours. 

 The list of stations are shown on table 1 and fig. 4. 
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Table 1 – Hydrometeostations in Prut and Siret basins. H – water level, Q – water discharge 
(calculated from stage-flow relationship curves), P – precipitation, T – air temperature, PR – 
air pressure, HU – air humidity, U – wind direction and speed, SH – sun hours. 

 

Hydrologocal Station River Measurements 

Tatariv Prut H, Q, P, T 

Yaremche Prut H, Q, T 

Kolomyia Prut H, T 

Vorokhta Prut H, Q, P, T 

Chernivtsi Prut H, Q, T 

Yaremche Zhonka H, Q, T 

Dora Kamyanka H, Q, P, T 

Lyubkivtsi Chornyava H, Q, P, T 

Usteriky Cheremosh H, Q, P, T 

Kuty Cheremosh H, P, T 

Yablunytsya White Cheremosh H, Q, P, T 

Verkvovyna Black Cheremosh H, Q, P, T 

Putyla Putyla H, Q, P, T 

Storozhynets Siret H, Q, P, T 

Verhny_Yaseniv Veretyn H, Q, P, T 

Iltsi Iltsya H, Q, P,T 

 

Meteorological stations  Basin Measurements 

Pozhezhevska Prut P, T, PR, HU, SH, U 

Yaremche Prut P, T, PR, HU, U 

Kolomyia Prut P, T, PR, HU, U 

Selyatyn Siret and Suchava P, T, PR, HU, U 

Chernivtsi Prut P, T, PR, RH, HU, U 
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Fig. 4  Sites of hydrological stations (blue points) and meteorological stations (red points) 
 

For calibration and verification of rainfall-runoff model TOPKAPI-U it was 

collected hydrometeorological data for period of 01.01.2003 – 31.12.2010. Collected 

data include water levels, discharges, precipitation, air temperature measured by 

hydrological stations and precipitation, minimal and maximal daily air temperature, 

daily wind speed, daile relative humidity and daily sun  hours for meteorological 

stations. Also it was collected daily flow and precipitation data for the same time 

period for Romanian hydrological stations Oroftiana (only precipitation) Radauti-Prut 

and Siret-Siret. 

 

Input GIS maps for hydrological model setup 

Rainfall-runoff model TOPKAPI-U utilizes following GIS data that cover 

watershed’s area: Digital Elevation Model (DEM); Flow directions and Slopes maps 

which are typically derived from DEM; Soils map; Landcover map; Monthly Leaf Area 

Index maps (LAI). Following datasets were used for hydrological model of Prut and 

Siret rivers basins: 

 Digital Elevation model SRTM DEM (http://srtm.csi.cgiar.org) with spatial 
resolution 1km (fig. 5). Flow directions and Slopes were derived from DEM 
using corresponding GIS algrorithms (fig. 6 – 7). 
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 Harmonized World Soil Database v.1.2 (fig. 8) with spatial resoultion 1 km 
(http://webarchive.iiasa.ac.at/Research/LUC/External-World-soil-
database/HTML/); 

 World Landcover dataset - GlobCover v.2.3 dataset (fig. 9) with spatial 
resolution 300 m (http://due.esrin.esa.int/page_globcover.php); 

 World Leaf Area Index dataset GLASS LAI (fig. 10) with spatial resolution 
(http://glcf.umd.edu/data/lai/description.shtml) with spatial resolution 1 km. 
 

 

Fig. 5  Digital Elevation Model 

 

Fig. 6  Flow directions map  

http://glcf.umd.edu/data/lai/description.shtml


The prevention and protection against floods in the upper Siret and Prut River Basins, through the 
implementation of a modern monitoring system with automatic stations – EAST AVERT Project 

 

9 

 

Fig. 7  Slopes map 

 

Fig. 8  Soils map 

 

Fig. 9  Landcover map 
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а) January 

 

b) February 

 

c) March 

 

d) April 

 

e) May 

 

f) June 

 

g) July 

 

h) August 
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i) September 

 

j) October 

 

k) November 

 

l) December 

Fig. 10  Seasonal Leaf Area Index (LAI) values for Prut and Siret rivers basins 

 

Measured crossections of Prut and Siret river 

It was measured 208 crossections of Prut, Cheremosh and Siret rivers (fig. 11). 

Crossections are used to setup hydrodynamic model RIVTOX for flow routing.  

 

Fig. 11   Sites of crossections surveys (red dots) 
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SIMULATIONS OF CATASTROPHIC FLOOD OF 2008 

Chapter presents results of implementation of TOPKAPI-U model for simulations of 

historical flow during catastrophic summer flood of 2008 for Prut river. Following figures 

shows the comparison of measured (red color) and simulated flow (blue color). 

  

  

  

  

  

Fig. 12   Observed and simulated flow for principal hydrological gauging stations 
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4.  Description of forecasting system workflow 

System comprises two servers, namely: Computational server of Numerical 

Weather Prediction model WRF which is situated in Chernivtsi, Water Resources 

Directorate of Prut and Dnister rivers basins (BUVR); Computational server of 

hydrological and hydrodynamic models TOPKAPI-U and RIVTOX (server “HYDROS”) 

which is situated in Chernitvtsi Hydrometeorological Center (ChGMC). Also system has 

connection via FTP with main database of Ukrainian Hydrometeorological Center 

(UkrGMC) for retrieving data of previous manual observations. 

 Principal scheme of data flow between servers is shown on fig. 13. 

 

Fig. 13  Principal scheme of data exchange within the System 

 

Every six hours numerical weather prediction model WRF calculates 

meteorological forecast with 96 hours lead time and time step 1 hour. WRF model 

produces NetCDF file that contains spatial fields of precipitation, air temperature, 

wind speed, relative humidity and incoming solar radiation with resolution 3x3 km   

(fig. 14).  

NetCDF file is processed by script which by means of bilinear or nearest 

neighbour interpolation recalculates WRF spatial fields on computational grid of 

rainfall-runoff model TOPKAPI-U. Interpolated grids are stored in corresponding HDF5 
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format file which is meteorological forcing file for model TOPKAPI-U. Before start of 

the hydrological forecasting, system retrieves last 15 days observation data of 

precipitation, water level, air temperature from the main server of UkrHMC. 

Accordingly to that data TOPKAPI-U and RIVTOX model update current watershed 

state for beginning time point of forecasts. On the next step hydrological and 

hydrodynamic models calculate forecast of water flow and levels with lead time 96 

hours for corresponding outlets – sites of 16 hydrological stations in Ukraine and 3 

stations in Romania, namely Radauti-Prut, Oroftiana-Prut and Siret-Siret. 

Final results are stored in database of forecasting system and may be viewed in 

user interface of “HYDROS” system.   

Scheme of described workflow is shown in fig. 15. 

 

 

Fig. 15  Workflow of hydrological forecasting for PRUT and Siret in UA  
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5.  HYDROS – the software system  integrating the modelling modules  of the 
forecasting system and providing the user interfaces  

The “Hydros” system has a client-server architecture, where the server is 
located in “DP BUVR” and clients can be located in both ChGMC and on other 
workstations. 

 

 
Fig. 16  “Hydros” system client-server architecture 

 

Computational module is responsible for initializing, launching models for 
performance and getting results. It stores information of tasks and each project you 
are working with at the moment. This component of the team with the manager runs 
the execution calculation engine model turns information from a unified data type in 
the format required for each model, collects and stores the results of calculations. 

Horizontal scaling is maintained at a calculator, that is, to increase productivity 
is possible to add new nodes, servers, processors. 

The user enters data through a graphical user interface. This data is transmitted 
via the Manager and Computation module in a unified data type format where the 
data are converted into a format of model, and sent to the calculation engine model. 
After finishing the simulation data is loaded into the shell model, wherein they are 
converted into system data types and are sent to the system kernel. Results may be 
stored in a database or displayed in a graphic user interface. 

The graphical user interface allows the operator of the system to provide  
convenient system management, input the necessary input data and visualization of 
calculation results and measurement data coming into the system. 

Main window containing map with Prut (outlet in Radauti) and Siret (outlet in 
Siret) river basins including water gages and meteo stations. 
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Fig. 17  “Hydros” graphical user interface 

 

The client part of the system is a user-oriented component, its’ main task is the 
displaying information to the user and sending data and requests to the Manager. The 
client provides a graphical interface, which consists of such modules: main module, 
models’ interface module, GIS module, reporting and visualization modules. 

The main module controls the other modules and is designed to provide the 
user with the appropriate functional and display the loaded projects. The main actions 
performed by the user is to create, copy, delete projects; up, the allocation of tasks 
within a project, the user interface for call patterns, call visualizer, display information 
from a database; group tasks, which is sent to the manager: initialization, startup 
performance problems and getting results. 

Module interface displays models of computational models and interfaces 
designed to collect parameters from the user, check the settings. Communication 
occurs through “dataitems” tree, which interface module receives from the main 
module. 

An important part of the data is georeferenced data, for which there is a 
geoinformation module. Geoinformation module is designed to display the spatio-
temporal and thematic data, which consist of digital terrain models (levels of heights, 
land-use categories, soil, rivers and lakes, settlements, boundaries of administrative 
areas, etc..), The results of calculations and information from the database ( Weather 
forecast maps, measurements of different characteristics). 

The HYDROS software system displays the results of the numerical weather 
forecasting model WRF: 

● Fields of precipitation 
● Field temperature 
● Wind field 
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● Humidity field 
Project Navigator has a tree structure: 

● Cards 
○ precipitation 
○ air temperature 
○ wind 
○ air humidity 

● Accumulated precipitation 
○ for 6 hours 
○ for 12 hours 
○ 24 hours 

● Charts and tables 
○ precipitation 
○ air temperature 
○ wind 
○ air humidity 

 

 
Fig. 18   Table view of accumulated precipitation per subwatershed for 24 hour period 
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Fig. 19  Map view. Air temperature field. 

 
 

 
Fig. 20  Computational grid of WRF model 
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Fig. 21  Precipitation map 

 

\ 

Fig. 22  Relative humidity map 
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Fig. 23  Wind field of WRF model 

 

Maps can be animated. Near the slider, that controls the animation, there is a 
list of all the forecast date to jump to the desired step forecast. 

Vertical - subwatersheds, horizontally - the forecast of steps (6, 12, 24 hours). 
Graphs and tables for each parameter are displayed in the central panel tab. These all 
weather stations and gauging stations are displayed one hectare plot and in the same 
table. To schedule the X-axis - forecast steps on the Y-axis - value. For horizontal table 
- forecasting steps, vertical weather station name or gauging. 

 

 
Fig. 24  Plot view of air temperature on Oroftiana and Radăuţi 
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Fig. 25 Table view of air temperature on Oroftiana and Radăuţi 

 

 

 
Fig. 26  Table view of minimum and maximum temperature 
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Fig. 27  Relative humidity plot view on Oroftiana and Radăuţi 

 

 

 
Fig. 28  Relative humidity table view on Oroftiana and Radăuţi 
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Fig. 29  Wind speed plot view on Oroftiana and Radăuţi 

 

 

 
Fig. 30 Table view of wind speed on Oroftiana and Radăuţi 
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Fig. 31  Plot view. Water levels on stations Oroftiana and Radăuţi 

 

 

 
Fig. 32 – Table view. Water levels on stations Oroftiana and Radăuţi 
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Fig. 33  Plot view. Water levels on stations Oroftiana and Radăuţi 

 

 

 
Fig.  34  Table view. Water discharge on stations Oroftiana and Radăuţi 
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Interface of 2D model COASTOX implemented for the modelling of “high rflood risk 
areas”  

 

 
Fig. 35 Flooding zone Chernivtsi site 

 

 

 
Fig. 36  Coastox model initialization window 
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Fig. 37  Coastox model running 

 

 

 
Fig. 38 Coastox model computational grid in user interface for Ust-Putila region 
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Fig. 39 Results of Coastox model. Water depth at point “p05” 

 

 

 
Fig. 40  Water depth map view of Ust-Putyla region 
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Fig. 41 1% Flood for site 01-Dubivtsi-Luzhany-Mamaivtsi-Chernivtsi. Full extent. CRS: WGS 
84/Pseudo-Mercator 

 

Fig. 42  1% Flood for site 01-Dubivtsi-Luzhany-Mamaivtsi-Chernivtsi. Zoom to Chernivtsi. CRS: 

WGS 84/Pseudo-Mercator 
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Fig. 43  0.1% Flood for site 01-Dubivtsi-Luzhany-Mamaivtsi-Chernivtsi. Full extent. CRS: WGS 

84/Pseudo-Mercator 

Fig. 44  0.1% Flood for site 01-Dubivtsi-Luzhany-Mamaivtsi-Chernivtsi. Zoom to Chernivtsi. 

CRS: WGS 84/Pseudo-Mercator 
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6.  The medium term hydrological rainfallrunoff modeling system for upper Siret and 
Prut River Basin 

 

In order to elaborate and provide medium term hydrological forecasts for the 
upper Siret and Prut river basins, at the entrance in Romania, a second conceptual 
rainfall-runoff model was implemented. These medium term forecasts are used in 
realtime to optimize the reservoirs operation in Siret and Prut River, downstream the 
entrance in Romania, during the flood events. 

This rainfall-runoff model will provide the inflow forecasts to Stânca Costesti, in 
order to support by scenarios simulations this important reservoir operations for flood 
management, for real-time decision support. 

Also, the short term forecasts elaborated with this system, could be used as a 
backup in real time, if situations when there are some problems / failure in running 
the detailed hydrological modeling system for the upper part of Siret and Prut River 
basins, in Ukraine.  

The implementation was done using the RS Minerve System - 
https://www.crealp.ch/fr/accueil/outils-services/logiciels/rs-minerve.html, a freely 
distributed software that could be used for the simulation of free surface runoff flow 
formation and routing, in complex hydrological and hydraulic networks using a semi-
distributed conceptual scheme.  

In addition to particular hydrological processes such as snowmelt, glacier melt, 
surface and underground flow, hydraulic control elements (gates, spillways, diversions, 
junctions, turbines and pumps) could also be included (Fig. 45). 

 

 
Fig. 45 General structure of the medium term hydrological forecasting system, for Prut and 

Siret River Basins, within the RS-Minerve modelling system 
 

https://www.crealp.ch/fr/accueil/outils-services/logiciels/rs-minerve
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This hydrological forecasting system configuration is based on the Sacramento 
Soil Moisture Accounting System (SACSMA) as rainfall-runoff model, the same model 
that is implemented and used in HFMS-DESWAT National system in Romania, in order 
to benefit from the experience in model configuration and calibration, and for a better 
integration with the existing system. 

The SAC-SMA (Sacramento-Soil Moisture Account) is a conceptual model This 
model that calculates the total discharge from the precipitation (P) and the potential 
evapotranspiration (ETP) depending on the parameters and initial conditions. 

The SACRAMENTO conceptual rainfall-runoff model was selected, considering, 
on the one hand, the structure of this hydrological model (Fig. 46-48), the runoff 
generation processes that it can simulate and especially the very long period and the 
good results obtained internationally by using this hydrological model in hydrographic 
basins with different physico-geographical conditions, respectively applying the model 
to different space-time scales. 

Another important aspect behind the selection of the SACRAMENTO rainfall-
runoff hydrologic model as an internal model within the hydrological modeling module 
was the existence of some a priori parameter estimation methodologies based on the 
link between the main parameters of this hydrological model and physico-
geographical conditions of a hydrographic basin, mainly depending on soil 
characteristics and land cover.  

These relationships have been defined on the basis of the conceptual physical 
significance associated with the parameters of this model, and the development of GIS 
processing techniques in recent years as well as the existence of GIS data sets with the 
main features of the soil and land cover available globally, allow a first identification of 
the calitative model parameter values for any hydrographic basin, which is especially 
important for the case of system implementation in unmonitored river basins and/or 
in river basins where there is insufficient quantitative and qualitative data for 
calibration of the model based on historical data. 

 
Fig. 46 The components of SAC-SMA conceptual hydrologic model 
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Fig. 47 The structure and parameters of SAC-SMA conceptual hydrologic model 
 

The parameters of SACRAMENTO model are described as follows: 

 UZTWM The upper layer tension water capacity 

 UZFWM The upper layer free water capacity 

 UZK Interflow depletion rate from the upper layer free water storage 

 ZPERC Ratio of maximum and minimum percolation rates  

 REXP Shape parameter of the percolation curve  

 LZTWM The lower layer tension water capacity 

 LZFSM The lower layer supplemental free water capacity 

 LZFPM The lower layer primary free water capacity 

 LZSK Depletion rate of the lower layer supplemental free water storage 

 LZPK Depletion rate of the lower layer primary free water storage 

 PFREE Percolation fraction that goes directly to the lower layer free water storages 

 PCTIM Permanent impervious area fraction  

 ADIMP Maximum fraction of an additional impervious area due to saturation  

 RIVA Riparian vegetation area fraction 

 SIDE Ratio of deep percolation from lower layer free water storages  

 RSERV Fraction of lower layer free water not transferable to lower layer tension water 

 STXT Soil texture of the upper layer 

 TBOT Climatological annual air temperature 
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Fig. 48 The conceptualization of main processes in SAC-SMA 
 

In the SACRAMENTO rainfall-runoff model, the soil horizons are structurally 
generalized in two specific areas, respectively an upper zone (generally considered to 
be the first 15 to 25 cm of soil) and a lower zone. The dynamics of water storage 
phenomena in the two areas is conceptually simulated by two categories of reservoirs: 
reservoirs with soil water content that is tightly bound to soil particles and does not 
move under the action of gravitational forces, water that does not contribute to the 
runoff, respectively free water reservoirs, which can move under the action of gravity 
forces and generate the surface runoff at the level of the hydrographic basin by 
different mechanisms. 
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7. HEC-RAS routing model for Prut River, downstream the entrance in Romania 

The hydraulic model of the Prut River was elaborated by S.C. AQUAPROIECT S.A. 

using the HEC-RAS software within "The prevention and protection against floods in 

the upper Siret and Prut River Basins, through the implementation of a modern 

monitoring system with automatic stations" (EAST AVERT) project. 

The HEC-RAS (River Analysis System) software has been developed by the 

Hydrologic Engineering Center (HEC), a department of the Institute of Water 

Resources (IWR) in the U.S. Corps of Engineer's. 

This system of programs covers a wide range of applications such as rainfall-

runoff analysis, flow analysis in case of natural flow regime / for rivers equipped with 

hydrotechnical works, flood extension analysis, real-time flow forecasting for the 

exploitation of reservoirs. 

Input data needs to be as accurate and up-to-date as possible in order to 

achieve successful results. 

Inputs for software are considered: 

 topographic data – the channel cross sections, the engineering structures 

descriptions (bridges, weirs, dams, water intakes, etc.), situation plans, aerial 

photos, digital terrain models etc.; 

 hydrological data - flow values in all interest sections, input hydrographs, 

measured hydrographs, rating curves, gate performance curves, historical 

flooded areas for calibration of significant events models etc.; 

 data regarding the hydrotechnical works scheme; 

 land use information, vegetation coverage, river bed and flooded area nature 

and  in order to establish the roughness coefficients; 

The goal is to obtain similar results to those determined by the real phenomenon. In 

order to achieve this, it is necessary to calibrate and validate the application. 

It is possible to obtain output data in tabular and graphical format for the channel 

cross sections, longitudinal profiles containing variation of the water level, flooded 

areas, water depths. 

The program consists of four main components: 

 steady flow analysis; 

 unsteady flow analysis; 

  sediment transport; 

  water quality analysis. 
 

The hydraulic modeling of the Prut River was elaborated for a length of approx. 

744 km, based on topobatimetric profiles measured in the field and / or DTM extracts 



The prevention and protection against floods in the upper Siret and Prut River Basins, through the 
implementation of a modern monitoring system with automatic stations – EAST AVERT Project 

 

36 

within flooded area boundaries. An analysis of the morphological configuration of 

each area was carried out and all the significant morphological characteristics that 

influence the process of hydraulic propagation of flow were taken into account. 

For areas where the flood flow is concentrated in one or more streams parallel 

to the main water course or in the flow areas behind the defense dykes, a loop system 

called quasi 2D modelling was used. 

The current hydrotechnical works scheme consisting of defense dykes along the 

Prut River on one river bank or on both river banks on the downstream sector of 

Stânca Costeşti reservoir imposed the construction of a hydraulic modelling system 

consisting of: 

 main channel of Prut River (between the dykes or between the dykes and the 

versant); 

 10 parallel streams and 9 storage areas on the right bank; 

 13 parallel streams and 20 storage areas on the left bank. 

The connection between the main channel of the Prut River and the parallel 

secondary streams, as well as the storage areas, was made using reversible spillway as 

hydraulic structure with the lengths and elevations of the spillway crests 

corresponding to the lengths and elevation crests of the dykes. The overflow of 

defense dykes was treated without considering any dyke breach. 

For the flow of synthetic flood waves for maximum discharges with the 

probability of exceedances of 0.1%, 0.5%, 1% and 10% through the Stânca Costești 

Reservoir, the provisions of the Regulation for the reservoir exploitation during the 

flood periods was taken into account. 

The calibration of the hydraulic model was done taking into consideration the 

historical floods from 2008 and 2010. 

The user interacts with the HEC-RAS software via an easy-to-use graphical 

interface (Fig. 49) with the following features: 

 File’s organization; 

 Data entry and editing; 

 Flow analysis; 

 View input or results in tabular or graphical form; 

 Mapping of flood extension; 

 Reporting facilities; 

 Online access to information related to the mathematical model used in 

software development and how to elaborate applications [9]. 
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Fig. 49  The graphical interface of the HEC-RAS software 

 

To create an application using the HEC-RAS software, you need to complete the 

following steps: 

To name and save the application 

By accesing the File menu, then the New project option, the project name must 

be mentioned and then it is necessary to save it into a dedicated directory (Fig. 50). 

From the Options menu, Select Units Options must be accessed to set the international 

measurement system. 

In order to open an already elaborated application, the user slects the Open 

project from the File menu. 

 
Fig. 50  Creation of a new project in the HEC-RAS software 

 

To Introduce the hydrographic network scheme geometry data 

In the Geometric Data editor (Fig. 51) following data must be specified: 

 hydrographic network scheme; 
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 cross sections; 

 engineering structures, 

and saved (Geometric Data -> File -> Save Geometry Data as). 

 

Fig. 51   Geometric Data editor 

The scheme of the hydrographic network comprises the river invert line, the 

channel cross sections, the tributaries and the hydrotechnical works positions (Fig. 52). 

For each watercourse, it is advisable to have separately hydrographic network 

scheme file in order to allow various flow scenarios to be created later. 

 

 
Fig. 52  View of  the hydrographic network scheme 
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The rivers invert line is described into Stereographic 1970 planar coordinates 

(Fig. 53), either by importing in a program-approved format (Geometric Data -> File -> 

Import Geometry Data) or by using Copy and Paste functions from an .xls file in the 

Reach Invert Lines Table in Geometric Data -> GIS Tools (after pre-setting the number 

of lines required in the Reach Invert Lines Table). 

 

 
Fig. 53  River invert line description 

 

For the description of river cross sections (Figure 54) the following data is required: 

 the plane coordinates of measured points on the river cross sections (Geometric 

Data -> GIS Tools -> XS Cut Line Table); 

 the river cross section identification number (River Section of Cross Section 

Data). The river cross sections are numbered along the river in ascending order 

from downstream to upstream; 

 the distances between the points measured on the river cross section and the 

elevation corresponding to these points (Station and Elevation in the Cross 

Section Data Editor). River cross sections are described by points from left to 

right; 

 a short description of river cross section, if it is the case, as text (for example: 

Gauge station cross section) to Description in Cross Section Data; 

 the distances from the downstream cross section, measured along the invert 

line and the two over bank areas (Downstream Reach Lengths in Cross Section 

Data); 



The prevention and protection against floods in the upper Siret and Prut River Basins, through the 
implementation of a modern monitoring system with automatic stations – EAST AVERT Project 

 

40 

 the roughness values of the channel and of the two over bank areas (Manning's 

n Values in Cross Section Data); 

 the banks channel position (Main Channel Bank Stations in Cross Section Data); 

 cross section contraction and expansion coefficients (Cont / Exp Coefficients in 

Cross Section Data) - the default values may be retained or may be changed, 

where applicable. 

The following additional information may be added to the river cross sections, 

where appropriate: 

 the positions and elevations of dykes - Cross Section Data -> Options -> Levees; 

 the positions and elevations of ineffective areas (ineffective areas contain 

water, but it is not actively transported) - Cross Section Data -> Options -> 

Ineffective Flow Areas; 

 the positions and elevations of flow obstruction areas (these areas do not 

participate in the flow process, nor do they prevent the water flow from 

overcrossing them) - Cross Section Data -> Options -> Obstractions; 

 the cross section rating curve - Cross Section Data -> Options -> Add a Rating 

Curve; 

 ice cover (mentioning the thickness of the ice layer in the channel and on the 

over bank areas, as well as their roughness values) - Cross Section Data -> 

Options -> Add Ice Cover; 

 the horizontal / vertical roughness value variation - Cross Section Data -> 

Options -> Horizontal / Vertical Variation in n Values. 

Cross section information can be imported in a program-approved format or can be 

entered manually. 

 

Fig. 54  Cross section description 
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The cross sections of the secondary parallel channels located in the over bank 

areas of the Prut River have been numbered with the same identification number as 

the main watercourse (Prut River) in order to facilitate the introduction of the lateral 

structures (the reversible spillways) through which they were connected. 

Roughness data include estimates of the roughness coefficients of the channel 

and of the two over bank areas for each cross section, and they are considered to be 

data with a greater degree of uncertainty. 

Among the factors influencing the value of channel roughness can be listed: 

 the nature of the riverbed and the average particle size; 

 irregularities of the channel; 

 riverbed shapes (such as ripple marks, dunes, transition forms and flat shapes); 

 river sector characteristics of erosion or deposition of alluvial material; 

 tendencies of meandering; 

 obstructions of the channel (tree trunks, dams built by the beaver, scraps of 

material that block the section, etc.); 

 changes in geometry of the cross sections; 

 the presence of vegetation on the riverbed and on the river banks.  

The roughness coefficient varies considerably with the period of the year, so it is 

recommended to estimate roughness values for the year season in which floods occur. 

In the estimation of the roughness coefficient, Chow's (1959) tables can be 

used, including the maximum, minimum and normal values of this coefficient for a 

variety of types of channel (natural / artificial, variable widths of cross section, 

different types of over bank areas). 

The best method of estimating the value of the roughness coefficient is to 

indirectly determine it based on the records from the gauges stations. 

In the "HEC - RAS - River Analysis System - Hydraulic Reference Manual", the 

following roughness values are proposed according to nature of riverbed and river banks 

(Table 2): 

Table 2:Manning coefficient recommended values 

Type of channel and description 
Manning coefficient n values 

minimu
m 

normal 
maximu

m 

1. Natural streams 

Clean, straight, full, no rifts or deep pools 0.025 0.03 0.033 

Same as above, but more stones and weeds 0.03 0.035 0.04 

Clean, winding, some pools and shoals 0.033 0.04 0.045 

Same as above, but some weeds and stones 0.035 0.045 0.05 

Same as above, lower stages, more ineffective slopes and 
sections 

0.04 0.048 0.055 
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Type of channel and description 
Manning coefficient n values 

minimu
m 

normal 
maximu

m 

Clean, winding, some pools and shoals, but more stones 0.045 0.05 0.06 

Sluggish reaches, weedy, deep pools 0.05 0.07 0.08 

Very weedy reaches, deep pools, or floodways with heavy 
stands of timber and brush 

0.07 0.1 0.15 

2. Mountain Streams, no vegetation in channel, banks usually steep, with trees and brush 
on banks submerged 

Bottom: gravels, cobbles, and few boulders 0.03 0.04 0.05 

Bottom: cobbles with large boulders 0.04 0.05 0.07 

Flood Plains 

a. Pasture no brush 

Short grass 0.025 0.03 0.035 

High grass 0.03 0.035 0.05 

b. Cultivated areas 

No crop 0.02 0.03 0.035 

Mature row crops 0.025 0.03 0.04 

Mature field crops 0.03 0.04 0.05 

c. Brush 

Scattered brush, heavy weeds 0.035 0.05 0.07 

Light brush and trees, in winter 0.035 0.05 0.06 

Light brush and trees, in summer 0.04 0.06 0.08 

Medium to dense brush, in winter 0.045 0.07 0.11 

Medium to dense brush, in summer 0.07 0.1 0.16 

d. Trees 

Cleared land with trees stumps, no sprouts 0.03 0.04 0.05 

Same as above, but heavy sprouts 0.05 0.06 0.08 

Heavy stamb of timber, few down trees, little 
undergrowth, flow below branches 

0.08 0.1 0.12 

Same as above, but with flow into branches 0.1 0.12 0.16 

Dense willows, summer, straight 0.11 0.15 0.2 

Linear or build-up Channels 

1. Concrete 

Trowel finish 0.011 0.013 0.015 

Float finish 0.013 0.015 0.015 

Finished, with gravel bottom 0.015 0.017 0.02 

Unfinished 0.014 0.017 0.02 

Gunite, good section 0.016 0.019 0.023 

Gunite, wavy section 0.018 0.022 0.025 

On good excavated rock 0.017 0.02 
 

On irregular excavated rock 0.022 0.027 
 

2. Concrete bottom  float finished with sides of 

Dressed stone in mortar 0.015 0.017 0.02 

Random stone in mortar 0.017 0.02 0.024 

Cement rubble masonry, plastered 0.016 0.02 0.024 
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Type of channel and description 
Manning coefficient n values 

minimu
m 

normal 
maximu

m 

Cement rubble masonry 0.02 0.025 0.03 

Dry rubble on riprap 0.02 0.03 0.035 

3. Gravel bottom with sides of 

Formed concrete 0.017 0.02 0.025 

Random stone in mortar 0.02 0.023 0.026 

Dry rubble or riprap 0.023 0.033 0.036 

4. Brick 

Glazed 0.011 0.013 0.015 

In cement mortar 0.012 0.015 0.018 

5. Metal 

Smooth steel surfaces 0.011 0.012 0.014 

Corrugated metal 0.021 0.025 0.03 

6. Asphalt 

Smooth 0.013 0.013 
 

Rough 0.016 0.016 
 

7. Vegetal lining 0.03 
 

0.5 

8. Excavated or Dredged Channels 

Earth, straight and uniform 

Clean, recently completed 0.016 0.018 0.02 

Clean, after weathering 0.018 0.022 0.025 

Gravel, uniform section, clean 0.022 0.025 0.03 

With short grass, few weeds 0.022 0.027 0.033 

Earth, winding and sluggish 

No vegetation 0.023 0.025 0.03 

Grass, some weeds 0.025 0.03 0.033 

Dense weeds or aquatic plants in deep channels 0.03 0.035 0.04 

Earth bottom and rubble side 0.028 0.03 0.035 

Stony bottom and weedy banks 0.025 0.035 0.04 

Cobble bottom and clean sides 0.03 0.04 0.05 

Dragline-excavated or dredged 

No vegetation 0.025 0.028 0.033 

Light brush on banks 0.035 0.05 0.06 

Rock cuts 

Smooth and uniform 0.025 0.035 0.04 

Jagged and irregular 0.035 0.04 0.05 

Channels not mantained, weeds and brush 

Clean bottom, brush on sides 0.04 0.05 0.08 

Same as above, highest stage of flow 0.045 0.07 0.11 

Dense weeds, high as flow depth 0.05 0.08 0.12 

Dense brush, high stage 0.08 0.1 0.14 
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The description of the engineering structures is also made in the Geometric 

Data editor: 

 bridges and culverts (Edit and / or create bridges and culverts); 

 inline structures (Inline structure); 

 lateral structures (Lateral structure); 

 water storage areas (Storage area); 

 pump stations (Pump stations). 

To describe a bridge (Figure 55), it is necessary to access the Edit and/or create 

bridges and culverts -> Options -> Add a Bridge and/or a Culvert window and indicate 

the identification number of the bridge (River Station). In the Deck / Roadway Data 

Editor, must be introduced the distance to the upstream cross section (Distance), the 

width  of the bridge (Width), the deck description indicating the positions and 

elevations of the contact points with the terrain on both sides of the upstream and 

downstream cross section (Upstream -> Station -> High Chord -> Low Chord și 

Downstream -> Station -> High Chord -> Low Chord). In the Pier Data Editor, the piers 

are described and the sloping abutments in the Sloping Abutment editor (Sloping 

Abutment Data Editor -> Options -> Add). 

 
Fig. 55 Bridge description 

To introduce the inline structure (Figures 56, 57) in the hydraulic model, the 

Inline Structure Data window (Inline Structure Data -> Options -> Add an Inline 

Structure) must be accessed and the identification number must be mentioned. In the 

Weir / Embankment, the information about the distance to the upstream cross section 

(Distance), the width at the base of the structure (Width), as well as the position and 

elevation of the construction beginning and end (Edit Station and Elevation 

coordinates). In the Gate window the dischargers of the dam are described, indicating 

the dimensions (Height  and Width), the elevation base of dischargers (Invert), the 
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positions (Station) and their performance curves (Enter/Edit User Defined Gate 

Performance Curves). 

 
Fig. 56 Dam description – upstream 

 

 

Fig. 57 Dam description – downstream 

 

To describe lateral structures on the watercourse, it is necessary to click the 

Lateral Structure Editor (Figure 58) -> Options -> Add a Lateral Structure and to 

indicate the structure identification number in the Lateral Structure Editor -> River 

Station, the bank side of the main river (Lateral Structure Editor -> HW Position), the 

type (Lateral Structure Editor -> Cross Section (s) of a River / Reach or Storage Area / 

2D Flow Area or Out of the system), the water course name and the sector (Lateral 
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Structure Editor -> Set TW RS -> River / River and Lateral Structure Editor -> Set TW RS -

> Sector / Reach), the upstream and downstream cross sections between which the 

structure is positioned and with which the flow connection  is made (Lateral Structure 

Editor -> Set TW RS ->US RS and Lateral Structure Editor -> Set TW RS ->DS RS) and the 

bank side of the water course (Lateral Structure Editor -> TW Position). In the Lateral 

Structure Editor -> Weir / Embankment, the information about the distance to the 

upstream profile (HW Distance to Upstream XS) is mentioned, how the discharge is 

flowing (TW flow goes -> To a point between two XS’s or TW flow goes -> Over 

multiple XS’s), Weir Width, as well as the highest elevation and the position of the 

construction begining and ending (Embankment Station/Elevation Table). The 

connection with the river (HW Connections) and the river sector (TW Connections) can 

be calculated automatically by selecting Computed Default Weir Stationing or can be 

introduced manually (User Defined Weir Stationing). 

 

 
Fig. 58  Description of the reversible spillway 

 

To enter the storage areas (Figures 59) connected to the spillways, in the Lateral 

Structure Editor -> Storage Area / 2D Flow Area is marked in the description of the spillway. 

Then, in the Geometric Data Editor, the Storage Area menu is activated and a polygon is 

drawn near the spillway and named. To enter the water volume that can be retained, right 

click on this polygon to select Edit Storage Area. For a 2D model, the Area Times Depth 

Method option can be ticked, and it is enough to indicate only the storage area surface (Area) 

and the minimum elevation area (Min Elev). For a 1D model, select the Elevation versus 

Volume Curve option and enter the capacity curve of the storage area. In the Lateral Structure 

Editor the storage areas are associated with the spillways (Set SA / 2D FA). 
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Fig. 59 a 

 

 
 

 

Fig. 59 b 
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Fig. 59 c 

 

 

 

 
 
 

 

 

 
 

Fig. 59 d. 
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Fig. 59 e. 

Fig. 59  Steps of storage area introduction in the hydraulic model 

 

To achieve the conection between two water courses, Geometric Data editor should 

be find data on the hydrographic network geometry of both rivers. The rivers may be 

imported into this editor (Geometric Data -> Import Geometry Data) if they were previously 

described, or the second one can be introduced following the steps previously mentioned. 

Using the Move Points / object function in the Geometric Data -> Edit -> Move point / 

objects, the most downstream point describing the riverbed invert line of the water course 

whose geometry has been imported must be moved in the way that is overlapping a point on 

the riverbed invert line of the other watercourse, in the confluence area. A dialog box opens 

which asks if you want to divide the main watercourse into two sectors in the next cross 

section downstream the confluence (Do you wish to split Prut River on reach Jijia?)  and for 

the YES option, another dialog box appears where the name of the downstream confluence 

sector is completed (A new reach will be created below split, enter the name: River – Prut, 

Reach – Prut downstream Jijia), and then the junction is named (for example, the Jijia 

confluence). By activating the Junction Data (Figure 60), the method of calculating the water 

level in the confluence neighborhood can be selected (Force Equal WS Elevation or Energy 

Balance Method). 
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Fig. 60 Junction Data editor 

 

To introduce the initial and boundary conditions  

In the Unsteady Flow Data editor initial and boundary conditions can be specified. 

Initial flow conditions (Figure 61) consisted of initial flow rates (Initial Flow) on 

both main and secondary water courses. In the Storage Area, the minimum elevation 

from which water volume retention begins is specified. 

 
Fig. 61  Introduction of initial conditions  
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The boundary conditions used in this hydraulic model are the following: 

 Flow Hydrograph - Figure 62. This condition has been introduced into the 

upstream sections of the watercourses; 

 Time Series of Gate Openings - from the dam dischargers and lateral reversible 

spillways (Figure 63); 

 Normal Depth. This condition was usually introduced into the downstream 

boundary sections of the watercourses, and allows a rating curve for the 

downstream cross section to be generated based on Manning's equation (Figure 

64); 

 Uniform distributed flow hydrograph between two sections, chosen by the 

user, on the water course (Uniform Lateral Inflow) - between cross sections 

422.2 ÷ 407.5 and 407 ÷ 361 on the Prut River (Figure 65); 

 Punctually Lateral Inflow Hydrograph - in the cross section 366 on the Prut River 

(Figure 66). 

Other boundary conditions (Figure 67) such as rating curves, flow and level 

hydrographs, level hydrographs, etc. may be introduced in the hydraulic model by 

adding the cross section in which one of the conditions is to be entered and by 

selecting the boundary. 

 

 

Fig.  62 Flow Hydrograph introduction 
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Fig. 63 Time Series of Dam Dischargers Openings introduction 

 

 
Fig. 64 Time Series of reversible spillways Openings and Normal Depth introduction 
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Fig. 65 Uniform Lateral Inflow Hydrograph introduction 

 

 

Fig. 66 Lateral Inflow Hydrograph introduction 



The prevention and protection against floods in the upper Siret and Prut River Basins, through the 
implementation of a modern monitoring system with automatic stations – EAST AVERT Project 

 

54 

 
Fig. 67  Boundary conditions introduction 

For each boundary condition involving a hydrograph, the Data time interval – 1 

hour (this value can be chosen from the implicit values of the software), and the time 

for the begining of the simulation (Fixed Start Time) – Date: 24th of July 2008, Time: 

1:00, were established. 

After all conditions are introduced in the hydraulic model, the file is saved 

(Unsteady Flow Data -> Save Unsteady Flow Data as). 

To run the application 

To run a scenario simulation (Perform an unsteady flow simulation), it is 

necessary to create a file (File -> New Plan) in which the hydrographic network scheme 

file - Geometry File and the one reffering to flow conditions - Unsteady Flow File 

(Figure 68) must be mentioned, and to save it, also specifing a Short ID for the 

scenario.  

The following information must also be mentioned: 

 The start and the end time for simulation (date and time) - Simulation Time 

Window; 

 The computation time step (Computation Interval); 

 The time step for result presentation (Mapping Output Interval, Hydrograph 

Output Interval, Detailed Output Interval); 

 The name of the result file (DSS Output Filename).  
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Fig. 68 Unsteady Flow Analysis editor 

To visualize the results 

The results of an unsteady flow simulation can be viewed in a tabular (Figure 

69) or graphic form. These may consist of hydrographs (Figure 70), rating curves 

(Figure 71), water levels in cross section (Figure 72) or represented in a longitudinal 

profile (Figure 73), water velocity values (Figure 74), flood extension etc. 

 

Fig. 69 Results visualization in a tabular form  
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Fig. 70 Flow and water level hydrograph visualization  

 

 
Fig. 71 Rating curve visualization  
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Fig. 72 Maximum water level in dam cross section visualization  

 

 

 

Fig. 73 Longitudinal profile visualization 
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Fig. 74  Water velocity values in cross section visualization 

 
 

8.  Summary of role and responsibilities sharing between project partners 

 PP6 will send to PP4 and PP7, in real time, the data from the automatic 
hydrometrical and meteorological stations data, using automatic data transfer 
procedures, for all the automatic stations installed within the EAST AVERT 
Project, using specific data communication and format agreed with PP4 and 
respectively PP7. 

 PP7 will send to PP4 the NWP forecasts from the numerical meteorological 
forecasting model implemented within EAST AVERT Project, using specific data 
communication and format agreed with PP4. 

 PP7 will send to PP4 the hydrological forecasts from the short term Hydrological 
Forecasting System implemented within EAST AVERT Project, using specific data 
communication and format agreed with PP4. 

 PP4 will retrieve from PP3, in real time, the data from the automatic 
hydrometrical station installed within the EAST AVERT Project. 

 PP4 will integrate and disseminate the data from the automatic hydrometrical 
and meteorological stations data received under this agreement, to all the 
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Dispatch and Forecast Centers of all project partners, using automatic data 
transfer procedures. 

 PP4 will send to PP7 the hydrological forecasts from the medium term 
Hydrological Forecasting System implemented within EAST AVERT Project, using 
specific data communication and format agreed with PP7. 

 PP4 will send to PP7 the meteorological forecasts used for the medium term 
Hydrological Forecasting System implemented within EAST AVERT Project, using 
specific data communication and format agreed with PP7. 

 PP4 will integrate and disseminate the hydrological data from the automatic 
hydrometrical and meteorological stations data received under this agreement, 
to all the Dispatch and Forecast Centers of other project partners, using 
automatic data transfer procedures. 

 PP4 will integrate the hydrological forecasts elaborated for the Upper Prut and 
Siret River Basins, with the hydrological forecasting systems implemented within 
EAST AVERT Project, and will generate specific hydrological forecasting and 
warning products, that will be disseminated to all the project partners. 

 


